APTX Blog

A Moe Blog Set Up By APTX

使用Enlighter替换Crayon Syntax Highlighter插件

文章目录[隐藏]

日常标题

Crayon Syntax Highlighter多年未更新了,已经不支持PHP7.3了,早换晚换都是换。

  • Option – Block CSS Selector 设为pre.EnlighterJSRAW, pre[class*="lang:"][class~="decode:true"]
  • Option – Inline CSS Selector 设为code.EnlighterJSRAW, span[class*="lang:"][class~="decode:true"][class~="crayon-inline"]
  • BETA – Dynamic Resource Invocation (DRI)必须关闭
  • 这样就可以兼容原插件了。

Via:https://blog.swineson.me/enlighter-compatibility-configuration-to-crayon-syntax-highlighter/

点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注